Author Topic: Ruleset troubleshooting {FMP recolor side-project}  (Read 1682 times)

Offline Quinch

  • Colonel
  • ****
  • Posts: 128
    • View Profile
Ruleset troubleshooting {FMP recolor side-project}
« on: November 28, 2014, 09:26:06 pm »
I'm working on a companion mod for the Final Mod Pack, but I'm hitting a snag - when I kill a Reptoid, one of the added alien races, the game CTDs. The same happens when I load a crashed UFO with a dead unit, leading me to believe that I may have a resource missing or misdefined, but I can't figure out what. The vanilla races act fine, both pre and post-mortem.

Any idea what I'm missing?

Offline Solarius Scorch

  • Global Moderator
  • Commander
  • *****
  • Posts: 9587
  • WE MUST DISSENT
    • View Profile
    • Nocturmal Productions modding studio website
Re: Ruleset troubleshooting {FMP recolor side-project}
« Reply #1 on: November 29, 2014, 04:34:06 pm »
Apart from a missing body picture/bad definition of it, I can't really say what the problem could be (I haven't checked the data yet).

Offline jackstraw2323

  • Colonel
  • ****
  • Posts: 208
    • View Profile
Re: Ruleset troubleshooting {FMP recolor side-project}
« Reply #2 on: November 29, 2014, 07:00:12 pm »
I'd say mis defined corpse in your rul, or a missing graphic. Have you tried running it through Falco's rule validator yet? Sometimes that turns up additional information for me when OSX doesn't provide a more specific crash.

Offline Quinch

  • Colonel
  • ****
  • Posts: 128
    • View Profile
Re: Ruleset troubleshooting {FMP recolor side-project}
« Reply #3 on: December 01, 2014, 08:51:26 am »
Alrighty, it's sorted now. I blindly stumbled into figured out what was wrong - drawing routines. I copypasted the parameters from Solarius' ruleset, but the spritesheet he used was a different one than what I was using, so using drawroutine 0 {sectoid} tried to pull on non-existent frames, rather than 14, which is the one designed for Tasoths.