Author Topic: Where's the memory, Lebowski?  (Read 6607 times)

Offline Dercik

  • Sergeant
  • **
  • Posts: 15
    • View Profile
Where's the memory, Lebowski?
« on: July 18, 2013, 11:46:48 pm »
When I tried to start crash site i get this message and CTD. Can someone tell me what's that suppose to mean?
« Last Edit: July 18, 2013, 11:50:14 pm by Dercik »

Offline SupSuper

  • Lazy Developer
  • Administrator
  • Commander
  • *****
  • Posts: 2159
    • View Profile
Re: Where's the memory, Lebowski?
« Reply #1 on: July 19, 2013, 03:13:03 am »
Congratulations, you managed to get an error that is never supposed to happen ever!

*ahem* It means something has gone seriously wrong with the application memory, either it got corrupt or ran out of space. If it happens again, try to get a save of it.

Offline kevL

  • Colonel
  • ****
  • Posts: 466
  • pitchforks and torches
    • View Profile
Re: Where's the memory, Lebowski?
« Reply #2 on: July 19, 2013, 08:42:59 am »
I just got it too, on gitbuild 2013_07_18_1326, when entering tactical. It goes away when i revert to 2013_07_16_1525.

- winXp SP3, modded ruleset + data files btw.

( .Sav attached, i hope.. )
« Last Edit: July 19, 2013, 08:50:43 am by kevL »

Offline Warboy1982

  • Administrator
  • Commander
  • *****
  • Posts: 2333
  • Developer
    • View Profile
Re: Where's the memory, Lebowski?
« Reply #3 on: July 19, 2013, 09:40:53 am »
oh god, what did i do?

edit: well this is frustrating... the error occurs in git-built versions, but my home compiler doesn't reproduce it...
« Last Edit: July 19, 2013, 10:10:16 am by Warboy1982 »

Offline kevL

  • Colonel
  • ****
  • Posts: 466
  • pitchforks and torches
    • View Profile
Re: Where's the memory, Lebowski?
« Reply #4 on: July 19, 2013, 11:26:57 am »
not sure what your voodoo is there but here's more info:


I tried again with original data, default ruleset, and only my Config & the .Sav in documents. ( i doubt my config has anything terribly unusual, 1680x1050x8 windowed & pinned @ 0,0, no OpenGL, no filters ) The .log says everything loads fine, then 10 seconds later when it enters Tactical:

[19-07-2013 02:03:05] [FATAL] Where's the memory, Lebowski?


The fault occurs between the "Exercise Caution" screen and soldier loadouts..... (the OK button sticks in the down position but music keeps playing.)

Offline pmprog

  • Commander
  • *****
  • Posts: 647
  • Contributor
    • View Profile
    • Polymath Programming
Re: Where's the memory, Lebowski?
« Reply #5 on: July 19, 2013, 04:48:43 pm »
Think we know what this is, just need to put it in the git, and see after the next nightly build :)

Offline Dercik

  • Sergeant
  • **
  • Posts: 15
    • View Profile
Re: Where's the memory, Lebowski?
« Reply #6 on: July 19, 2013, 05:25:03 pm »
I just got it too, on gitbuild 2013_07_18_1326, when entering tactical. It goes away when i revert to 2013_07_16_1525.

- winXp SP3, modded ruleset + data files btw.

( .Sav attached, i hope.. )

Yeah exactly. I was using the same version and 2013_07_17_1143 which also gave me the error. Now I am using 2013_07_17_0618 and everything works fine :).

Offline kevL

  • Colonel
  • ****
  • Posts: 466
  • pitchforks and torches
    • View Profile
Re: Where's the memory, Lebowski?
« Reply #7 on: July 20, 2013, 08:24:41 am »
all good :)

Now if I could just stop killing more of my own guys than the aliens do.


*grenade hits side of the Skyranger* oops