Author Topic: vaporColorSurface (dont work) OXCE 7.0  (Read 1007 times)

Offline RSSwizard

  • Commander
  • *****
  • Posts: 766
    • View Profile
vaporColorSurface (dont work) OXCE 7.0
« on: November 10, 2023, 11:09:54 pm »
i dont want to upgrade because it might break my version of xpz (L9)
but the hypervelocity mod says its compatible with 6.8+...
yet after adding transparency LUTs and setting vapor colors they do not appear.

wat do?
« Last Edit: November 10, 2023, 11:12:20 pm by RSSwizard »

Offline Yankes

  • Commander
  • *****
  • Posts: 3229
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #1 on: November 10, 2023, 11:15:56 pm »
if its very old mod it could be break by making LUT tables not shared by all mods (similar like other resources work).
Probably shifting indexes in items could fix it.

Offline RSSwizard

  • Commander
  • *****
  • Posts: 766
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #2 on: November 11, 2023, 02:53:49 am »
shifting indexes? what does that mean?

I literally just used what is in the screenshot, didn't use nodes or anything like that, like literally its just the difference between (tftd) vaporColor and the surface version.

Offline Yankes

  • Commander
  • *****
  • Posts: 3229
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #3 on: November 11, 2023, 03:42:23 pm »
Could you post whole mod, not only partial screenshot of it? I can't check png file if its work as rules with game.

Offline RSSwizard

  • Commander
  • *****
  • Posts: 766
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #4 on: November 11, 2023, 07:56:32 pm »
this is a code-inject mod which means the file is simply dropped in the piratez folder and added to the rest of the stack, nothing else in the mod deals with these aspects here though (file naming also means it is applied last)

Offline Yankes

  • Commander
  • *****
  • Posts: 3229
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #5 on: November 12, 2023, 12:05:56 am »
this is a code-inject mod which means the file is simply dropped in the piratez folder and added to the rest of the stack, nothing else in the mod deals with these aspects here though (file naming also means it is applied last)
Ok, and this is problem, `transparencyLUTs` can't work in files like this. It need be in special "resource" file that is one per whole mod.

Offline RSSwizard

  • Commander
  • *****
  • Posts: 766
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #6 on: November 13, 2023, 04:24:54 am »
actually scratch that...
I made this change and it still doesn't do it.

Offline Yankes

  • Commander
  • *****
  • Posts: 3229
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #7 on: November 13, 2023, 08:21:57 pm »
What change and how exactly?

Offline RSSwizard

  • Commander
  • *****
  • Posts: 766
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #8 on: November 15, 2023, 05:57:07 am »
1. added "resourceConfig: transparency.rul" to the mod's metadata.yml. It did not have one prior to this.

2. copypasted the transparencyLUTs into that new file, but nothing else, removed them from the file I posted here.

Didn't do anything else.

Offline Yankes

  • Commander
  • *****
  • Posts: 3229
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #9 on: November 15, 2023, 11:56:26 am »
Could you post whole mod? as this should work.

Offline RSSwizard

  • Commander
  • *****
  • Posts: 766
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #10 on: November 17, 2023, 04:20:44 am »
I know that's what im wondering. Its basically just xpiratez version L9 which hasn't had anything done to its core files, ive just added stuff like this. Is there something wrong with vaporColorSurface in OXCE 7.0?  Do ammo items need to have a vaporDensity as well or is the alpha value in the LUTs good enough?  I know the TFTD items have a vaporDensity but none of them in the hyper velocity master have a density value defined.

Offline Yankes

  • Commander
  • *****
  • Posts: 3229
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #11 on: November 17, 2023, 11:11:37 am »
I can't answer this if you do not show whole mod, I will not guess if you do not mess up something.

Offline zee_ra

  • Colonel
  • ****
  • Posts: 200
    • View Profile
Re: vaporColorSurface (dont work) OXCE 7.0
« Reply #12 on: December 05, 2023, 04:40:50 am »
I can't answer this if you do not show whole mod, I will not guess if you do not mess up something.

@RSSwizard

An alternate approach might be to concoct a mode snippet that illustrates your problem.  A minimal sub-fragment may be much more amenable to being shared publically.