aliens

Author Topic: X-com files: Missing clip STR_HUMAN_SONIC_SHOTGUN on pop_os!  (Read 2517 times)

Offline sculptasquad

  • Squaddie
  • *
  • Posts: 4
    • View Profile
X-com files: Missing clip STR_HUMAN_SONIC_SHOTGUN on pop_os!
« on: April 08, 2023, 08:31:49 pm »
So I managed to install and run openxcomextended on pop_os! and I was looking forward to get my favourite mod (x-com files) up and running. I installed it into the mod folder and went to activate it in game, but I get the error message:

ERROR: failed to load "X-Com Files"; mod disabled
Weapon STR_HUMAN_SONIC_SHOTGUN has a clip size 0 and no ammo defined. Please use "clipSize: -1" for unlimited ammo, or allocate a compatibleAmmo item.

Does anyone know how I can solve this issue and get stuck in killing fish-faced cultists?

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 8686
    • View Profile
Re: X-com files: Missing clip STR_HUMAN_SONIC_SHOTGUN on pop_os!
« Reply #1 on: April 08, 2023, 08:38:35 pm »
Hi, can you attach the whole log file please?

Offline sculptasquad

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: X-com files: Missing clip STR_HUMAN_SONIC_SHOTGUN on pop_os!
« Reply #2 on: April 08, 2023, 09:14:43 pm »
Is this it?

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 8686
    • View Profile
Re: X-com files: Missing clip STR_HUMAN_SONIC_SHOTGUN on pop_os!
« Reply #3 on: April 08, 2023, 09:40:20 pm »
Is this it?

Yes, that's it.

The log file says that you're using OpenXcom, not OpenXcom Extended.

XcomFiles requires OpenXcom Extended to run.

Offline sculptasquad

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: X-com files: Missing clip STR_HUMAN_SONIC_SHOTGUN on pop_os!
« Reply #4 on: April 08, 2023, 10:04:19 pm »
I tried downloading the linux version of open x-com extended, pasted and replaced the files into my xcom folder, but the openxcomextended executable won't run.

Online Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 8686
    • View Profile
Re: X-com files: Missing clip STR_HUMAN_SONIC_SHOTGUN on pop_os!
« Reply #5 on: April 08, 2023, 10:35:14 pm »
I have close to no experience with Linux.

Maybe someone else can help...

Offline sculptasquad

  • Squaddie
  • *
  • Posts: 4
    • View Profile
Re: X-com files: Missing clip STR_HUMAN_SONIC_SHOTGUN on pop_os!
« Reply #6 on: April 08, 2023, 10:45:48 pm »
Thx anyway.

Offline R1dO

  • Colonel
  • ****
  • Posts: 438
    • View Profile
Re: X-com files: Missing clip STR_HUMAN_SONIC_SHOTGUN on pop_os!
« Reply #7 on: April 08, 2023, 11:17:20 pm »
I tried downloading the linux version of open x-com extended, pasted and replaced the files into my xcom folder, but the openxcomextended executable won't run.

In order to help, some more info is needed.
* With "won't run" you mean: "Nothing happens when trying to start" or "It always shows some error" ?
* Could you check if the executable has the permission "executable" set (the latest download seem to have it set, but this is just to be sure).
* Are you trying to run it via the GUI (e.g. clicking an icon) or via terminal commands?