aliens

Author Topic: I can't make the latest linux version works on Fedora 38.  (Read 371 times)

Offline FoxBolder

  • Squaddie
  • *
  • Posts: 1
    • View Profile
I can't make the latest linux version works on Fedora 38.
« on: August 18, 2023, 10:18:41 am »
So I tried my best, i'm not an expert in linux, I'm only on fedora since a couple weeks.

First I had trouble finding the correct paths to install the game's file and Appimage launcher. Then when I tried to launch the X-files mod, I had the STR_HUMAN_SONIC_SHOTGUN wich I understand is because OXCE wasn't installed. So I made a fresh folder with fresh UFO files from X-COM: UFO Defense. First I extracted the latest linux version then I copied the files. The thing is that I can't launch OpenXcomEx and I did make it executable.

I tried to get my hands on the compilation instructions, but failed in the end. It would be really helpful if someone on fedora who's been succesful in making OXCE work could help me cause I really tried, but I have reached the limit of my linux beginners knowledge and hit a wall.

Thank you.

Edit: Ok now it's working. What I did ? Installed the dev libraries. Made a fresh install using the latest Linux build and transfered the mod into user/mods. I had problem cause I was trying to install the mod into the OXC folder in the ./local/share/openxcom so it could't work.
« Last Edit: August 18, 2023, 11:53:00 am by FoxBolder »

Offline Yankes

  • Commander
  • *****
  • Posts: 3158
    • View Profile
Re: I can't make the latest linux version works on Fedora 38.
« Reply #1 on: August 18, 2023, 11:13:59 am »
Code: [Select]
but failed in the endThis mean exactly? OXCE should be easy compilable on any modern Linux.