aliens

Author Topic: Buggy self compiled v1.0 / Nightlies / OXCE on Linux  (Read 312 times)

Offline incas

  • Sergeant
  • **
  • Posts: 22
    • View Profile
Buggy self compiled v1.0 / Nightlies / OXCE on Linux
« on: September 21, 2022, 06:02:33 pm »
I compiled the game often in the past without any issues. Now I have massive issues with scrolling, mouse wheel usage and sfx sound.
I'm on Fedora Linux and compile with Meridian's or wiki instructions without any errors.

Strangely when I use the openxcom Linux-Appimage it works fine. https://openxcom.org/download/nightlies/OpenXcom_20210611_8d45159bf_x86-64.AppImage
I compiled the exact same commit hash and again problems. Is it some compiler or library problem?

Code: [Select]
cmake .. -DCMAKE_BUILD_TYPE=Release -DDEV_BUILD=OFF -DBUILD_PACKAGE=OFF
-- The C compiler identification is GNU 12.2.1
-- The CXX compiler identification is GNU 12.2.1
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/lib64/ccache/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/lib64/ccache/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD - Success
-- Found Threads: TRUE 
-- Found PkgConfig: /usr/bin/pkg-config (found version "1.8.0")
found SDL 1.2.56 (/usr/lib64:/usr/include/SDL)
found SDL_mixer 1.2.12 (/usr/lib64:/usr/include/SDL)
found SDL_gfx 2.0.26 (/usr/lib64:/usr/include/SDL)
found SDL_image 1.2.12 (/usr/lib64:/usr/include/SDL)
found yaml-cpp(/usr/lib64:/usr/include;/usr/include/..)
-- Found OpenGL: /usr/lib64/libOpenGL.so   
found openGL (/usr/lib64/libGL.so;/usr/lib64/libGLU.so)
-- Found Git: /usr/bin/git (found version "2.37.3")
git found: /usr/bin/git
Found doxygen:/usr/bin/doxygen
-- Configuring done
-- Generating done
-- Build files have been written to:

Code: [Select]
Installed Packages
Name         : yaml-cpp-devel
Version      : 0.6.3
Release      : 6.fc36
Architecture : x86_64
Size         : 112 k
Source       : yaml-cpp-0.6.3-6.fc36.src.rpm

Edit: Problems are mostly noticeable on Battlescape. Scrolling to the sides is very erratic with the mouse. Mousewheel to change levels is moving the screen to the side. Sfx begin to deteriorate after a while. Mousewheel usage for things like changing manufacturing units (tested in XPZ) not working either in Geoscape.
« Last Edit: September 21, 2022, 06:11:49 pm by incas »

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7604
    • View Profile
Re: Buggy self compiled v1.0 / Nightlies / OXCE on Linux
« Reply #1 on: September 21, 2022, 06:55:36 pm »
Code: [Select]
found SDL 1.2.56 (/usr/lib64:/usr/include/SDL)

...looks strange. As far as I know, latest SDL1 version is 1.2.15

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7604
    • View Profile
Re: Buggy self compiled v1.0 / Nightlies / OXCE on Linux
« Reply #2 on: September 21, 2022, 07:04:18 pm »
Just googling SDL 1.2.56 pointed me to: https://github.com/libsdl-org/sdl12-compat

So probably you're using (or being forced to use by your OS) sdl12-compat instead of SDL1... which hasn't been tested.

Offline incas

  • Sergeant
  • **
  • Posts: 22
    • View Profile
Re: Buggy self compiled v1.0 / Nightlies / OXCE on Linux
« Reply #3 on: September 21, 2022, 07:08:46 pm »
Code: [Select]
found SDL 1.2.56 (/usr/lib64:/usr/include/SDL)

...looks strange. As far as I know, latest SDL1 version is 1.2.15

That might be it. There is no SDL1 in the repositories :o
only this
Code: [Select]
sdl12-compat-devel.x86_64 : Files to develop SDL 1.2 applications using SDL 2.0

https://fedoraproject.org/wiki/Changes/SDL12onSDL2
Quote
SDL 1.2 development ended long ago, with SDL 2.0 replacing it. However, many older games still use SDL 1.2 and cannot change to SDL 2.0. In order to help move SDL 1.2 games into the modern world, let's replace SDL 1.2 with sdl12-compat, which uses SDL 2.0.

Quote
User Experience

There shouldn't be a noticeable user impact, other than possibly a smoother experience because applications are using SDL 2.0.
Huh?

Damn. Will it work/compile correctly perhaps with SDL 2 installed or do I need to compile SDL 1 myself? Hmm.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7604
    • View Profile
Re: Buggy self compiled v1.0 / Nightlies / OXCE on Linux
« Reply #4 on: September 21, 2022, 07:11:55 pm »
Out of the box, it won't compile with SDL2.


Offline incas

  • Sergeant
  • **
  • Posts: 22
    • View Profile
Re: Buggy self compiled v1.0 / Nightlies / OXCE on Linux
« Reply #5 on: September 21, 2022, 07:16:56 pm »
https://wiki.libsdl.org/SourceCode

Found it here, hopefully I can make it work with that. The sdl devs seem to hate, that people still  use 1.2  ;D

Offline incas

  • Sergeant
  • **
  • Posts: 22
    • View Profile
Re: Buggy self compiled v1.0 / Nightlies / OXCE on Linux
« Reply #6 on: September 21, 2022, 07:47:37 pm »
I think Opengl needs to be build with sdl 1.2 as well for OpenXcom to build. I give up. I'll use Wine... :-X

Offline psavola

  • Captain
  • ***
  • Posts: 56
    • View Profile
    • Email
Re: Buggy self compiled v1.0 / Nightlies / OXCE on Linux
« Reply #7 on: September 21, 2022, 08:48:47 pm »
I think Opengl needs to be build with sdl 1.2 as well for OpenXcom to build. I give up. I'll use Wine... :-X

No need to use Wine unless you really want to. You can grab a "bionic" image from https://lxnt.wtf/oxem/#/Extended - works just fine directly on Linux.

Offline incas

  • Sergeant
  • **
  • Posts: 22
    • View Profile
Re: Buggy self compiled v1.0 / Nightlies / OXCE on Linux
« Reply #8 on: September 21, 2022, 09:02:44 pm »
Not sure how it was build but I tried 7.5.3 (for XPZ) and it is buggy for me too. ???
So only the appimage of the older version and Wine work without the issues it seems.

Offline SupSuper

  • Lazy Developer
  • Administrator
  • Commander
  • *****
  • Posts: 2158
    • View Profile
    • Email
Re: Buggy self compiled v1.0 / Nightlies / OXCE on Linux
« Reply #9 on: September 22, 2022, 07:10:47 am »
I've opened a bug on sdl12-compat for you: https://github.com/libsdl-org/sdl12-compat/issues/215
Can you post your system info? (Fedora version, SDL2 version, etc)

Offline incas

  • Sergeant
  • **
  • Posts: 22
    • View Profile
Re: Buggy self compiled v1.0 / Nightlies / OXCE on Linux
« Reply #10 on: September 23, 2022, 07:40:07 pm »
Thank you! I'll post it to Github.