Author Topic: OXCE > 40K mod > Installation issues >  (Read 334 times)

Offline Noob-Tech-Ninja

  • Squaddie
  • *
  • Posts: 2
    • View Profile
OXCE > 40K mod > Installation issues >
« on: July 12, 2022, 08:52:30 pm »
Hi there guys

I was hoping that you could help me with an issue that I've been having with
trying to get a new mod installed and working for Openxcom

Background:
I've been playing Openxcom for a good while now, and I've completed the game
a couple of times and loved it !

I've seen a few of the mods available and I'm really interested in the WH40K mod

Originally I have been using an older version of Openxcom =
(OpenXcom_20210227_2a4462942_x86-64.AppImage) to play the game.
This has been working flawlessly (on its own, without trying to use mods).


However I have downloaded and installed Openxcom Extended =
Extended-7.5.3-f94c8c56f-2022-02-07-bionic-x86_64

(As I believe that this is requirement for running the 40K mod)

I can play the base game without any issues, but I'm not able to get any of the
mods to work.


Issue & Troubleshooting:
I cannot get the WH40K mod to run.

These are the main error messages I see when installing the 40k mod into the
mods dir, and then trying to run the game -

Error logs:
(See attatchement)

Questions:
1. What do I need to do, in order to get this / these mods installed and
working ?

2. Do I need the ROSIGMA mod working, to allow me to use the 40K mod ?

3. Is there anything else that I need to do, to get these mods working ?


Useful information:

Openxcom version: Extended-7.5.3-f94c8c56f-2022-02-07-bionic-x86_64

40K Mod version: 0.29


PC details:
OS: Linux - Ubuntu 22.04 (LTS) (64 bit)
DE: KDE (Plasma): version: 5.18.8
Kernel version: 5.14.0-1044-oem
CPU: x4 Intel Core 2 (Q8200) @2.33 Ghz
RAM: 8 GB

TIA for any help and advice.
« Last Edit: July 12, 2022, 09:17:24 pm by Noob-Tech-Ninja »

Offline Yankes

  • Moderator
  • Commander
  • ***
  • Posts: 2868
    • View Profile
Re: OXCE > 40K mod > Installation issues >
« Reply #1 on: July 12, 2022, 09:18:24 pm »
You probably use too old version of 40k, or too new version of OXCE.
Each new version of OXCE add new checks for mod correction, this have bad side effect as break old mods that have some inconsistency.
Because of this possibility you can reduce level of user config `oxceModValidationLevel` to smaller value. But then warranty is void and game is allowed to miss behave or crash at any moment :)

Offline Noob-Tech-Ninja

  • Squaddie
  • *
  • Posts: 2
    • View Profile
Re: OXCE > 40K mod > Installation issues >
« Reply #2 on: July 13, 2022, 01:28:44 am »
Hi Yankes

Thanks very much for the quick reply.
I've removed and then re-added the 40k mod again (for the 4th time ?)

For whatever reason, it actually worked this time !

I've managed to run the game, and play the game/mod.

I also got utterly annihilated on my 1st mission
(But hey, thats X-Com baby)

Thanks again mate, much apprecaited !