Author Topic: [SOLVED] After installing xcom files mod, oxce won't run game anymore- Linux  (Read 1106 times)

Offline happyalien

  • Squaddie
  • *
  • Posts: 6
    • View Profile
I ran into a problem trying to run X-Com Files in Linux Mint.

I'm running the native (linux) version of oxce (7.4.4)

I got Xcom Ufo defense from internet archive (the ISO file called xcom-ufo-defense). I then copied the files from that iso into the UFO folder inside the newly created oxce folder. I then did "chmod +x OpenXcomEx". I get an error saying I have to install some files. so I install the 3 files (and their dependencies in synaptic). I don't recall the exact names of the 3 files, but I remember "lib" being part of them. Anyway, I then rerun OpenXcomEx and I see the Microprose logo and then the Xcom screen. So far so good.


Now I get the zip file called openxcom_xfiles_2.2. I unpack the contents (all 3 folders) into the mods folder (inside the . local folder)

I then run OpenXcomEx again. I then click the Mods button on the lower left. I then click Yes on the "X Com files with Cyrlic characters" row. It then restarts but then I get this error message (please see attachment).

Here's some text from that:
Quote
ERROR: During linking rulesets of soldiers:
Error for ‘STR_DOG’ : Soldier type is missing the default armor
Error for ‘STR_HYBRID’ : Soldier type is missing the default armor
Error for ‘STR_MUGGLE_AI’ : Soldier type is missing the default armor
Error for ‘STR_RAT’ : Soldier type is missing the default armor

« Last Edit: January 29, 2022, 08:55:35 am by happyalien »

Offline happyalien

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Here is the log file
[28-01-2022_21-55-59]   [INFO]   OpenXcom Version: Extended 7.4.4 (v2022-01-21)
[28-01-2022_21-55-59]   [INFO]   Platform: Linux
[28-01-2022_21-55-59]   [INFO]   Data folder is:
[28-01-2022_21-55-59]   [INFO]   Data search is:
[28-01-2022_21-55-59]   [INFO]   - /home/happyalien/.local/share/openxcom/
[28-01-2022_21-55-59]   [INFO]   - /usr/share/cinnamon2d/openxcom/
[28-01-2022_21-55-59]   [INFO]   - /usr/share/gnome/openxcom/
[28-01-2022_21-55-59]   [INFO]   - /home/happyalien/.local/share/flatpak/exports/share/openxcom/
[28-01-2022_21-55-59]   [INFO]   - /var/lib/flatpak/exports/share/openxcom/
[28-01-2022_21-55-59]   [INFO]   - /usr/local/share/openxcom/
[28-01-2022_21-55-59]   [INFO]   - /usr/share/openxcom/
[28-01-2022_21-55-59]   [INFO]   - /usr/local/share/openxcom/
[28-01-2022_21-55-59]   [INFO]   - /usr/share/openxcom/
[28-01-2022_21-55-59]   [INFO]   - ./
[28-01-2022_21-55-59]   [INFO]   User folder is: ./user/
[28-01-2022_21-55-59]   [INFO]   Config folder is: /home/happyalien/.config/openxcom/
[28-01-2022_21-55-59]   [INFO]   Options loaded successfully.
[28-01-2022_21-55-59]   [INFO]   SDL initialized successfully.
[28-01-2022_21-56-00]   [INFO]   SDL_mixer initialized successfully.
[28-01-2022_21-56-00]   [INFO]   Attempted locale: C.UTF-8
[28-01-2022_21-56-00]   [INFO]   Detected locale: C.UTF-8
[28-01-2022_21-56-00]   [INFO]   Attempting to set display to 1366x710x8...
[28-01-2022_21-56-00]   [INFO]   Display set to 1366x710x8.
[28-01-2022_21-56-00]   [INFO]   Loading data...
[28-01-2022_21-56-00]   [INFO]   Scanning standard mods in ''...
[28-01-2022_21-56-00]   [INFO]   Scanning user mods in './user/'...
[28-01-2022_21-56-00]   [ERROR]   FileMap::mapExtResources(xcom2, TFTD): external resources not found.
[28-01-2022_21-56-00]   [INFO]   Active mods:
[28-01-2022_21-56-00]   [INFO]   - xcom1 v1.0
[28-01-2022_21-56-01]   [INFO]   Loading begins...
[28-01-2022_21-56-01]   [INFO]   Pre-loading rulesets...
[28-01-2022_21-56-01]   [INFO]   Loading vanilla resources...
[28-01-2022_21-56-02]   [INFO]   Loading rulesets...
[28-01-2022_21-56-02]   [INFO]   Loading rulesets done.
[28-01-2022_21-56-02]   [INFO]   Loading fonts... Font.dat
[28-01-2022_21-56-02]   [INFO]   Lazy loading: 1
[28-01-2022_21-56-02]   [INFO]   Loading custom palettes from ruleset...
[28-01-2022_21-56-02]   [INFO]   Making palette backups...
[28-01-2022_21-56-02]   [INFO]   After load.
[28-01-2022_21-56-02]   [INFO]   Loading ended.
[28-01-2022_21-56-02]   [INFO]   Data loaded successfully.
[28-01-2022_21-56-02]   [INFO]   Loading language...
[28-01-2022_21-56-02]   [INFO]   Language loaded successfully.
[28-01-2022_21-56-02]   [INFO]   OpenXcom started successfully!
[28-01-2022_21-56-02]   [INFO]   Playing flx, 320x200, 890 frames
[28-01-2022_21-56-02]   [INFO]   Using software scaling routine. For best results, try an OpenGL filter.
[28-01-2022_21-56-03]   [INFO]   SDL_mixer initialized successfully.
[28-01-2022_21-56-10]   [INFO]   SDL_mixer initialized successfully.
[28-01-2022_21-56-10]   [INFO]   Loading data...
[28-01-2022_21-56-10]   [INFO]   Scanning standard mods in ''...
[28-01-2022_21-56-10]   [INFO]   Scanning user mods in './user/'...
[28-01-2022_21-56-10]   [ERROR]   FileMap::mapExtResources(xcom2, TFTD): external resources not found.
[28-01-2022_21-56-10]   [INFO]   Active mods:
[28-01-2022_21-56-10]   [INFO]   - xcom1 v1.0
[28-01-2022_21-56-10]   [INFO]   - XCF-CyrNames vAzrael, 20/SEP/2019
[28-01-2022_21-56-12]   [INFO]   Loading begins...
[28-01-2022_21-56-12]   [INFO]   Pre-loading rulesets...
[28-01-2022_21-56-12]   [INFO]   Loading vanilla resources...
[28-01-2022_21-56-12]   [INFO]   Loading rulesets...
[28-01-2022_21-56-13]   [INFO]   Loading rulesets done.
[28-01-2022_21-56-13]   [INFO]   Loading fonts... Font.dat
[28-01-2022_21-56-13]   [INFO]   Lazy loading: 1
[28-01-2022_21-56-13]   [INFO]   Loading custom palettes from ruleset...
[28-01-2022_21-56-13]   [INFO]   Making palette backups...
[28-01-2022_21-56-13]   [INFO]   After load.
[28-01-2022_21-56-13]   [ERROR]   During linking rulesets of soldiers:
Error for 'STR_DOG': Soldier type is missing the default armor
Error for 'STR_HYBRID': Soldier type is missing the default armor
Error for 'STR_MUGGLE_AI': Soldier type is missing the default armor
Error for 'STR_RAT': Soldier type is missing the default armor

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7488
    • View Profile
The "X-Com Files Cyrillic Names" submod cannot run alone.

It requires the "X-Com Files" parent mod.

I then click the Mods button on the lower left. I then click Yes on the "X Com files with Cyrlic characters" row.

You forgot to activate the "X-Com Files" mod/basegame between these two steps.
« Last Edit: January 29, 2022, 08:26:39 am by Meridian »

Offline happyalien

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Hi Meridian,
I don't see  the "X-Com Files" parent mod.
Please  see the two attached screenshots to see what I see in the Mods list.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7488
    • View Profile
It's right there on the first screenshot

Offline happyalien

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Hi Meridain,
ACcording to a youtube video tutorial (https://youtu.be/3tajiuNmNDE?t=219)  "X-Com Files" should be in that long list of mods. It should appear in a row, with the up and down button and the Yes/No toggle. So I'm a bit confused your annotation (your circling some words) on my screenshot.

Anyway, if that youtube video tutorial is wrong or not current anymore (the youtube vid is Nov  2019, using  oxce version 1.0), please let me know exactly what to click/do in that screen you drew circles on. Thank you so much.

UPDATE: I figured it out. I should just click the  "OKAY" box after i switch over to the XCom Files in the dropdown list on the top. thank you, sir.

Offline Meridian

  • Global Moderator
  • Commander
  • *****
  • Posts: 7488
    • View Profile
The video is old.

You need to select the base game "X-Com Files".

Offline happyalien

  • Squaddie
  • *
  • Posts: 6
    • View Profile
Thank you, Meridian. :) Can now enjoy XCom Files.