Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Pony

Pages: [1]
1
Help / Re: [solved] languages special characters [use UTF8]
« on: October 05, 2018, 02:01:48 pm »
OK,  I made a few tests, yet not 100% sure, but I'll just put it here in case it helps someone in the futur:

*Switching from ANSI to UTF8 without BOM in notepad++ (edit and save file) doesn't seem to work, as it's back to ANSI next time I reload the file in notepad++
*open in regular Notepad and save as UTF8 does convert from ANSI to UTF8, but add a BOM.
*open a UTF8 with BOM in  notepad++, switch to UTF8 without BOM, edit and save does seem to definitely convert the file into UTF8 without BOM (checked with a hex editor)


BOM BOM BOOOOOM
BOM BOM BOOOOOOOOOOM
Bom-bom-bom Bom-bom-bom Bom-bom-bom

2
Help / Re: [solved] languages special characters [use UTF8]
« on: October 04, 2018, 05:41:47 pm »
Hi !

Yeah sorry, never heard of BOM before seeing it in sup super screenshot (than Google it to get a basic understanding of what it was). I was able to replicate what he showed me, but it's just configure the display of the file in notepad++. Than I thought of regular notepad to resave while changing the setting from ANSI to UTF8 cause I knew it could do it from something else from years ago. But there was no no-BOM option, that's why I mentioned it in my post, thinking "someone will say something if it's really a problem", as it seemed to work anyway with or without BOM. With or without BOM, I can't live with or without BOM.

You react days later, but your posts are so edited, I have no idea... is it fine or not? How can I transform from UTF8 into UTF8 without BOM,  if it's a problem ?

3
Help / Re: languages special characters
« on: October 01, 2018, 10:03:37 am »
YES !

That was it, my files were in ANSI. I used regular notepad to re-save as UTF8, and it works.

Thanks for your help and sorry to have bother you with something that simple that i couldn't figure by myself.

By the way, thanks for all the work you've done (with others) to remake this awesome game.  I used to play ufo:eu when I was a kid, and replayed it from time to time for 20 years. This summer, I reinstalled it to play it with my 12 yo nephew... he loved it and now I'm hooked again, and with OpenXcom I can play without bugs and mod the shit out of it.

[edit]

4
Help / [solved] languages special characters [use UTF8 without BOM]
« on: October 01, 2018, 07:48:15 am »
Hello,

When I use extraString to input ufopedia new strings in different languages, I encounter a problem with special characters from certain languages. Like the é â è in french. They display correctly when it's from the vanilla fr.yml file. But when I imput them in a custom .rul using extraString,  they display in game as ? ? ? If I write a custom .yml myself in my mod, it doesn't work either.

Obviously, the font image files and the font.dat do include them, it just doesn't use them when I write them in any of my mod files, but does when it's in the regular language .yml file.

My code:
Languages.rul

extraStrings:
   - type: fr
     strings:
        STR_WHATEVER_UFOPEDIA: "my text here"

I did exactly like it is written in the equal term mod https://github.com/KingMob4313/Equal-Terms-Mods/blob/master/v1.0/data/Ruleset/EqualTerms_Weapons_v103.rul
If you have encountered that issue before, thank you for your help !

5
Help / Re: female power suit
« on: September 27, 2018, 06:18:25 pm »
Got it ! You have been really helpful, I'm not into faces yet and the game rewriting the sprites and stuff is a little bit scary, when I see what it does to a simple png. I have to go through animations now and grab a spritesheet example from the forum because pckview crash with big files, and a MEDIBORD.PCK because the image on the ufopaedia is a .jpg

I think I need to download more mods, even if I don't play them, to look at their ruleset,  as the exemple you provided really helped me understand what the game was looking for.

I will add SOLVED to the title of this thread now, maybe?

6
Help / Re: female power suit
« on: September 27, 2018, 04:49:39 pm »
Holy carrot, it works !!!
Thank you very much  ;D

So I have to put 8 entries (2 genders and 4 ethnic groups) in extrasprites each time I make a new MAN armor, else if there is one missing it shows the original armor that is replaced,  or crash if it's a new item ?

Here is what I've done so far, now I have to draw the animations. (see attachement, I don't know how to post an image).
 
It's my first attempt at drawing pixel art. I'm not entirely satisfied with the results, and the indexed color thing is infuriating... but I will improve !

7
Help / [SOLVED] female power suit
« on: September 27, 2018, 07:40:25 am »
Hello, I'm trying to make a male and female version of power and flying suit in UFO. How do I write the armor.rul and extrasprites.rul to use one image for male and another one for female in the inventory (like the armors in tftd that have different inventory image for male and female).

How does the game make the difference between the armor 0 & 1 which have different images for gender and ethnic groups, to other armors that have only one inventory image. In armor.rul they just write man_0 and hop, it's possible to imput different images.

Thank you for any help you could provide, I really tried to find the information before asking.

8
Area 51 / terrain pack 4.1 STR_PACIFIC game crash & possible solution
« on: September 24, 2018, 05:40:34 pm »
Hello, I hope this is the correct place to report my issue.

The game crashed at the end of the month, log says :
Error processing mission script named: superhuman difficulty,  region named STR_PACIFIC is not defined

I have openxcom 2018 09 04 0255 and only terrain pack 4.1 installed. But I recently installed terrain pack 4.1 and than the game crashed at end of month.  I couldn't reproduce because I suppose the game picked other regions than pacific to put missions in it when  reloading a save just before end of month.

I took a look into the Terrain pack geoscape.rul and it deletes all regions before recreating them with areas, mission weight and mission zones. But I noticed that STR_PACIFIC is deleted and than split into North pacific and south pacific that are created.

I suppose that the deprecated PACIFIC region got picked at start of next month to play missions in it, but it no longer exist as it is now split into North and South, so the game crashed. But reloading is fine because odds are another region will be picked... until next time.

My attempt at correcting the problem is to edit my save to change the 2 places where STR_PACIFIC is used (alienstrategy : regions and possiblemissions) and duplicate the entries than writing SOUTH_ and NORTH_ between STR_ and PACIFIC word. No problem, as the 2 newly created regions have the same regionweights and missionweights as the former pacific region.

Because the alien strategy is picked at start of game than written into the save.(A pretty similar problem could arise if the Pacific region was picked the previous month before installing the terrain pack, and the wave of ufo for the mission in Pacific region is not finished before the region get split into north and south by the mod.)

I hope this will fix the problem and will help maybe other simple minded people who thought this mod was just adding new terrain tiles and installed it in middle of a long game where they got bored of the same vanilla terrains.

I suppose the lesson is to always start a new mod with a fresh game.


Pages: [1]