Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - RedRedSuit

Pages: [1]
1
Released Mods / Re: [COMPILATION][RESEARCH] FMP Core/Tech Tree part
« on: August 03, 2014, 07:32:27 pm »
In options have a option i remember better sprites or similar. This adjust the sprites to resolution try enable or disable it

Unfortunately that did not fix it.

It looks like this person had exactly the same problem -- they seem to be running on Linux (also a Unix'y OS). 

https://openxcom.org/forum/index.php?topic=2160.msg23182#msg23182

Could it have something to do with Unix line endings or something along those lines?  What can we do to help fix it?

2
Work In Progress / Re: [The Final Mod Pack] Basic Weapons part
« on: August 03, 2014, 07:30:53 pm »
Some features certainly weren't planned, but I'm glad you're having fun. :P

Seriously though, is anyone else having similar problems? As I said, it works perfectly fine to me; now I don't know if it's the norm or an exception.

I am having this problem definitely!  I posted about it in https://openxcom.org/forum/index.php?topic=2027.390.  By the looks of it, this guy is running on Linux; I am running on Mac.  Both are Unix-based systems.  Maybe that's the commonality.  Do you know anyone who knows what they're doing X-COM development-wise who could look into it?

3
Upon further investigation, it seems to have something to do with either high resolutions or full-screen mode.  Like if I set it to Windowed and 640x480 or something, then I can enable filters smoothly.  However if I make the resolution go too high, ormake it full-screen again, it goes bonkers and shows super-zoomed in again.  So it's not totally broken... probably someone's insight can make it work.

It also seems to be confused what resolution is what, in general.  Like if I set it to Resizable, and then make the window cover almost the entire screen, the resolution it says it is using is not close to 1080p (whereas it should be close to 1920x1080)... it's more like 1200-by-something.  That seems consistent with its behavior at 1920x1080p/full-screen: it shows a much larger image than 1920x1080.

EDIT: After messing with it more, Resizable with a filter on, and then manually dragged to be a bit smaller than the screen -- that's probably the best option at the moment for me.  Everything is OK, except for the annoyances: difficult edge-scrolling, seeing the window title bar, taskbar appears if I touch bottom of screen... etc.  Full-screen would be great.

4
Hi there.  I should note that OpenXcom on Mac OS X 10.8 had no such issue for me.  All the filters worked great (I like HQ2x), and there is no tearing.

This is Windows 7, 1920x1080p HD TV (over HDMI with an nVidia 670), OpenXcom 1.0.

I have it set to 1920x1080p, fullscreen.  If I enable a filter in Video options, except for Scaled, it breaks oddly. The graphics look right, but the image is super-zoomed-in, so that the entire screen is showing maybe the middle 50% of what it should be showing.

If I disable the filter, then everything is fine except for these annoyances:

- the intro doesn't play full-screen but instead kind of on the upper-left;
- I have to Alt-Enter a few times for the image to center and scale properly;
- major screen tearing in Battlescape when I scroll around (it's playable though).

To be honest if I could just get rid of the tearing, that's all I really require.  It'd be nice to get the filters to work though.

5
Released Mods / Re: [COMPILATION][RESEARCH] FMP Core/Tech Tree part
« on: August 03, 2014, 05:26:30 am »
So, is this a graphics problem or something with your hardware after all?

Bear in mind I've never really seen a Mac in my life, therefore... :)

It looks like a software problem to me, either something with the mod files or OpenXcom.  I just now installed OpenXcom 1.0, applied universal patch, then applied this mod and enabled it.  Then New Battle from main menu.  Here is what heavy laser looks like when soldier looks right vs. down.

So something is wrong.  Anyone else seen this?  What could it be?

If I disable the mod, heavy laser looks normal.

UGH, SO FRUSTRATING!

EDIT: Works fine in Windows though.  :(

6
Released Mods / Re: [COMPILATION][RESEARCH] FMP Core/Tech Tree part
« on: August 03, 2014, 04:10:41 am »
I must have messed up somehow but...

game works great with this mod, but I've equipped a couple of new weapons (Sniper Rifle, Shotgun), and in Battlescape they look super-weird, like sort of greenish and divided into a bunch of sections.  It looks like a glitch.  Any idea what I did wrong and/or how to fix it?

Also, just ran into some sectoids, and their weapons look odd too.

Vanilla weapons look normal.

EDIT: Apparently the weirdness is only when looking, like, horizontally right along the screen.  If facing vertically down along the screen, looks fine.  This is OS X 10.8, by the way.

7
Builds & Ports / Re: Mac OS X port debug & testing
« on: August 02, 2014, 10:34:19 am »
This feels like an incredibly stupid question, but....

How do I switch out of OpenXcom in OS X, without quitting?  The normal thing -- Cmd-Tab -- does not work.  I have to fully quit the game.

Thanks.

I seem to have found an answer, kind of... alt-enter to go into windowed mode, alt-enter to go back.

8
Builds & Ports / Re: Mac OS X port debug & testing
« on: August 02, 2014, 09:54:09 am »
This feels like an incredibly stupid question, but....

How do I switch out of OpenXcom in OS X, without quitting?  The normal thing -- Cmd-Tab -- does not work.  I have to fully quit the game.

Thanks.

Pages: [1]