Author Topic: Bugs & Crash Reports  (Read 460178 times)

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5276
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #1455 on: March 18, 2017, 03:32:23 pm »
DL the new version.

Offline Marza

  • Colonel
  • ****
  • Posts: 121
    • View Profile
Re: Bugs & Crash Reports
« Reply #1456 on: March 18, 2017, 07:57:13 pm »
Ported my latest campaign to the new version. In the research screen, some of the entries (Aye-phone, Hypno panels, The Solar Governor) have had their names default to their vanilla counterpart (Motion sensor, Alien Entertainment, The Martian Solution).

I'm quickly looking through Piratez_lang.rul right now, but I haven't yet found anything obvious.

EDIT: Disregard above. Changed language options from UK to US.

Offline Adak

  • Squaddie
  • *
  • Posts: 2
    • View Profile
Re: Bugs & Crash Reports
« Reply #1457 on: March 18, 2017, 10:41:02 pm »
DL the new version.

Works like charm :-)

Offline karadoc

  • Colonel
  • ****
  • Posts: 208
    • View Profile
Re: Bugs & Crash Reports
« Reply #1458 on: March 19, 2017, 02:12:13 am »
Using v0.99 F4,

The game hangs (becomes unresponsive and must be forced to close) at the end of the day on my current save. I don't have any strong guesses for what is causing it, but I suppose it's probably something to do with research (since that's a significant thing that happens at the end of each day).

Save attached.

Offline karadoc

  • Colonel
  • ****
  • Posts: 208
    • View Profile
Re: Bugs & Crash Reports
« Reply #1459 on: March 19, 2017, 04:55:28 am »
I wanted to be able to continue playing my game, so I took the time to debug this problem. I've identified the problem, and posted a patch which fixes it. I was posting on Discord as I worked through it. For reference, here's what I said on Discord:

Quote
I've opened it in a debugger, and found that it's caused by a recursive infinite loop inside SavedGame::getDependableResearchBasic
That function calls itself; and in this case it just continues to call itself indefinitely. I'm not yet sure what the function is meant to do, so I don't have a solution yet.
My best guess at the moment is that there is a tech which either lists itself as a prerequisite, or lists itself as an unlock.
Ok.. On second examination it might be a bit more complex. It could be a few different techs which list each other as unlocks. Obviously we could work out which techs are the problem by looking at what I'm researching the in save, but I think it's better to just fix the problem in the exe.
I've got an easy fix in mind. I'll post it in a minute.
ok. Done
Check this out, @Meridian

https://github.com/karadoc/OpenXcom/commit/ff1dfdf9728dab6bd41882548d2768a804b9b600
Code: [Select]
GitHub
Fixed infinite loop bug in SavedGame::getDependableResearchBasic...
Loops of techs which unlock each other would previously cause this function to recursively call itself indefinitely. Techs which mutually unlock each other should now work correctly without problems.

Offline Balbinator

  • Sergeant
  • **
  • Posts: 18
    • View Profile
Re: Bugs & Crash Reports
« Reply #1460 on: March 20, 2017, 11:54:16 am »
0.99F.3
Can`t kill stunned enemy on this tile.
I have to pick him and move tile SE or SW and then shoot him on ground.

Offline Martin

  • Colonel
  • ****
  • Posts: 441
    • View Profile
Re: Bugs & Crash Reports
« Reply #1461 on: March 23, 2017, 10:42:27 pm »
It is minor but some of the oponents in eurosyndicate mission spawn with precision laser but no ammo for it.

Offline RSSwizard

  • Colonel
  • ****
  • Posts: 439
    • View Profile
Re: Bugs & Crash Reports
« Reply #1462 on: March 24, 2017, 01:03:13 am »
0.99F.4
This crash has happened before but only now has it repeated.
First time it happened when I received 2 cloaking devices at one of my bases, clicked on "check yer hideout" and the game instantly crashed. There was no listed error, there was nothing listed in the crash log - the Game Window just disappeared without further ado.

(after I ran the game again it worked just fine)

Happened again today, this time for simply starting a new manufacturing project. Nothing got added to available build items on the previous research completion, though I forget what it is I was going to build. As soon as I click on New Production the game window disappeared.

It happened again and this time I caught a screen of it because the window didnt go away (it just ended up not responding).

Seems more like an OXCE+ error but I figured id post it here since this is under x-piratez.

Edit:
Its doing it every time now, whether its at that base or the other base (their inventories are different). The most recent research topic unlocked was a Gun Almanac that gave me the CAWS shotgun.

I also got a Segmentation Default crash when I got another Gun Almanac researched but I dont know what item caused it - I tried to check the research results and it crashed without showing the item screen. Since the Gun Almanac gives a random get one free there's no telling which item it was.

(but this was NOT a segmentation default upon Game Load, this occurred during geoscape gameplay)

Methinks there is something fishy in your Manufacture Tree.

I started a new game just to see if it was going to keep hanging on me and the answer is no - however starting a new game just because, then loading my main savegame didnt keep it from crashing later.
« Last Edit: March 24, 2017, 02:40:28 am by RSSwizard »

Offline RSSwizard

  • Colonel
  • ****
  • Posts: 439
    • View Profile
Re: Bugs & Crash Reports
« Reply #1463 on: March 24, 2017, 03:20:25 am »
and now its NOT crashing

I think my computer has a mind of its own sometimes.

Offline Roxis231

  • Colonel
  • ****
  • Posts: 487
  • Catching the feral kitten hiding in my rubish bin
    • View Profile
Re: Bugs & Crash Reports
« Reply #1464 on: March 24, 2017, 09:30:49 am »
I'm think it's a problem from a T.S.R. file - an Antivirus program, Windows Media Player, the Task Manager ect... - You know, the ones that still run in the background, even after you close them.

They have affected my copy of Open X-Com before, however it's kinda hard to sort out which one is the culprit.

Offline RSSwizard

  • Colonel
  • ****
  • Posts: 439
    • View Profile
Re: Bugs & Crash Reports
« Reply #1465 on: March 24, 2017, 07:23:38 pm »
I'm think it's a problem from a T.S.R. file - an Antivirus program, Windows Media Player, the Task Manager ect... - You know, the ones that still run in the background, even after you close them.

They have affected my copy of Open X-Com before, however it's kinda hard to sort out which one is the culprit.

Thats entirely possible, I almost never reboot or shut down my computer, I put it in Hibernate because the ethernet/wifi is funky about not being able to turn it back on if it gets turned off due to low power or standby mode. Also I frequently have things going on in programs that I dont want to close (and a nagging fear sometimes that if I shut it down, it wont properly cold boot when I turn it back on).

Also I discovered a bug in OXCE+ that I didnt want to report, since im using a mod on top of xpiratez to modify stuff in the game. Rather than delete the Mandrake Linux SMG manufacturing entry and make a new entry so the manufacturing requirements were discarded, I simply modified str_sectoid_corpse: 0 without removing it.

Apparently the game code really didnt like that. I didnt see that coming since 0 is just another number and I didnt anticipate the code would barf when I did that. I guess because it would still have to print Integrated Devices under the manufacturing requirement and then also say it didnt require any (you'd think it would show up as Integrated Devices... units required 0)

(I dislike deleting entries and redefining them because if Dioxine changes the Listorder it will become a spaghetti mess and things will be shuffled to the bottom)

But it has also been insta-crashing for other reasons, like when i simply checked my base after I got those cloaking devices for the shipbuilding. Nothing has been changed about those.
« Last Edit: March 24, 2017, 07:27:05 pm by RSSwizard »

Offline Balbinator

  • Sergeant
  • **
  • Posts: 18
    • View Profile
Re: Bugs & Crash Reports
« Reply #1466 on: March 26, 2017, 02:58:41 pm »
0.99F4
Inaccessible room with enemy inside (pogrom map)

Offline legionof1

  • Commander
  • *****
  • Posts: 1527
  • Bullets go that way. Money comes this way.
    • View Profile
Re: Bugs & Crash Reports
« Reply #1467 on: March 26, 2017, 04:43:36 pm »
 :o how did i never notice that before? must have played pogroms on that tileset at least 30-40 times by now. But not game breaking given how flimsy most building walls are. Still time to move a door.

Offline Dioxine

  • Moderator
  • Commander
  • ***
  • Posts: 5276
  • punk not dead
    • View Profile
    • Nocturnal Productions
Re: Bugs & Crash Reports
« Reply #1468 on: March 26, 2017, 05:16:53 pm »
Hobbes' terrain hijinks. Not fixing this now, it'll be more efficient to do a general sweep/upgrade of ALL these terrains at once (building up workshop for someone's elses terrain takes time).

Offline Balbinator

  • Sergeant
  • **
  • Posts: 18
    • View Profile
Re: Bugs & Crash Reports
« Reply #1469 on: March 27, 2017, 10:38:57 pm »
And again - how to obtain "plasma subrifle"?
Who is using this gun? I`ve destroyed 4 bases and nothing...
Maybe it should be buyable? Or replace it with reticulan plasma gun???