OpenXcom Bug Tracker
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
Closed Bug report #667 Audio settings do not apply to intro sound effects
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Not a bug" and resolution "CAN'T FIX".
Description
With the SFX and UI volume settings turned all the way down, I still hear sound effects during the intro. This is problematic because the sound effects are drowning out multiple software MIDI synthesizers (Munt and BASSMIDIDRV) whose volumes are at maximum.
Steps to reproduce this issue
Open Options->Audio. Set UI and SFX volumes to minimum. Restart game to view intro. Observe that sound effects are still audible.
Comments (4)
#2
user-offline.png  volutar (Volutar)
Jul 13, 2014 - 08:10
Not an issue. It was made intentionaly, because music and sfx in intro is part of intro, and not allowed to be muted "partially". Maximum volume from sfx/music is used for both sfx and music.
#3
user-offline.png  HunterZ (HunterZ)
Jul 13, 2014 - 13:41
Well, as I said it is the maximum volume part that is the issue, as the game sound is drowning out the sound from MIDI synthesizers. It would be nice if all parts of the game would respect that I requested a certain configuration via the options menu.
#4
user-offline.png  volutar (Volutar)
icon_reply.pngAug 19, 09:16, in reply to comment #3
Don't use midi. Midi doesn't have proper volume control, so it screws system volume slider.

I'd recommend to remove "midi" from the list of supported formats at all, but some people prefer stupid wub-wub during battlescape (though they can grab one of 25 of pre-recorded tracks from Fenyo's site http://users.atw.hu/xcom-sounds/).

Intro music and accompanied sounds are intentonally lined-up to max of them, so noone could listen for the intro music without SFX or vice versa.

HunterZ wrote:
Well, as I said it is the maximum volume part that is the issue, as the
game sound is drowning out the sound from MIDI synthesizers. It would be
nice if all parts of the game would respect that I requested a certain
configuration via the options menu.


#5
user-offline.png  Warboy (Warboy)
Sep 27, 2014 - 18:12
microsoft saw it in their infinite wisdom to remove midi as a device, and as such SDL cannot handle the volume properly.

The issue was updated with the following change(s):
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to CAN'T FIX.
  • This issue's progression has been updated to 100 percent completed.
History
Issue basics
  • Type of issue
    Bug report
  • Category
    Not determined
  • Status
    Not a bug
  • Progress
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (1)
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Resolution
    CAN'T FIX
  • Reproducability
    Not determined
  • Severity
    Not determined
  • Nightly / Git version
    Not determined
  • Platform
    Windows 7 x64
  • Master Game
    Not determined
  • Mods
    Not determined
Attachments (0)
There is nothing attached to this issue
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)